Page 7 of 7 FirstFirst ... 567

Thread: '86 Comanche Long bed, Slow build...

  1. #61
    Join Date
    May 2011
    Location
    Mancos, CO
    Posts
    1,162
    Quote Originally Posted by AZJim View Post
    That looks great. Good to see it up and running, you had a major project going. What's next doing an extended cab Comanche? My brother and father both bought new '87s. Loved them just found it hard to get comfortable, I always wanted the seat to move back further. One had buckets and the other bench and they both felt the same.
    If I remember correctly, wasn't the firewall modified in '87 to allow room for the long 4.0.

    Jim
    Next... bed rack/ soft topper to hold the RTT. And Monstaliner in the bed. The firewall on the 86's was indeed not the same as 87 up, and you have to beat it to fit a 4.0l. That made the 3.4 v-6 a much easier swap.
    '06 GMC K2500 CCSB D/A w/ '94 Hallmark Ute 8.5'
    '86 Jeep Comanche
    '00ish Jeep TJ Scrambler
    '99 XR400R
    I'm my own boss now, I do what I want!!!
    KB9SCX

  2. #62
    Join Date
    Jan 2015
    Location
    Bend, Oregon, USA
    Posts
    341
    Very nice truck

  3. #63
    Join Date
    Dec 2015
    Location
    Rochester Hills, MI
    Posts
    90
    Awesome looking truck!
    1988 Ford Bronco II 4x4- SOLD. 1995 Ford Ranger 4x4- SOLD. 1989 Ford Ranger 4x4- TRADED. 1998 GMC Safari- TRADED IN 2016 Ford Focus 1.0 L Ecoboost- CURRENT.

  4. #64
    Join Date
    Jul 2015
    Location
    Mont Belvieu, Texas
    Posts
    78
    Any updates to this truck OP?
    2017 Ram 2500 6.4 Hemi Off Road PKG
    2015 Jeep JKUR

  5. #65
    Join Date
    May 2011
    Location
    Mancos, CO
    Posts
    1,162
    Quote Originally Posted by Kingsize24 View Post
    Any updates to this truck OP?
    Wow, I owe this thread an update!

    I built a bed rack and mounted a RTT for the summer. We took it camping several times and it was awesome.

    I was getting convinced that it had a head gasket issue, but a different radiator cap seems to have fixed that.

    My wife drives it daily and it really is working well. I'll find some pictures from camping this summer and post them later.
    '06 GMC K2500 CCSB D/A w/ '94 Hallmark Ute 8.5'
    '86 Jeep Comanche
    '00ish Jeep TJ Scrambler
    '99 XR400R
    I'm my own boss now, I do what I want!!!
    KB9SCX

  6. #66
    Join Date
    Jul 2017
    Location
    Kelowna BC
    Posts
    53
    Damn too bad photobucket killed all your pics, I would love see them.
    You weren't kidding that timing chain is looooooose!

  7. #67
    Join Date
    May 2011
    Location
    Mancos, CO
    Posts
    1,162
    Quote Originally Posted by Andrew_S View Post
    Damn too bad photobucket killed all your pics, I would love see them.
    You weren't kidding that timing chain is looooooose!
    I'll try to get them migrated to expo soon, but in the meantime, there IS a workaround for some browsers!!
    Search "photobucket hotlink fix". You'll see apps for Firefox and Chrome. (If you're not using one of those two browsers, you need to start.)
    All you have to do is find the app, click the "install" button, and voila, pictures show up!
    Enjoy,
    Chris
    '06 GMC K2500 CCSB D/A w/ '94 Hallmark Ute 8.5'
    '86 Jeep Comanche
    '00ish Jeep TJ Scrambler
    '99 XR400R
    I'm my own boss now, I do what I want!!!
    KB9SCX

  8. #68
    Join Date
    Jun 2014
    Location
    Louisville Kentucky
    Posts
    849
    Quote Originally Posted by 1stDeuce View Post
    I'll try to get them migrated to expo soon, but in the meantime, there IS a workaround for some browsers!!
    Search "photobucket hotlink fix". You'll see apps for Firefox and Chrome. (If you're not using one of those two browsers, you need to start.)
    All you have to do is find the app, click the "install" button, and voila, pictures show up!
    Enjoy,
    Chris
    You, sir, are a saint.

  9. #69
    Join Date
    Jul 2017
    Location
    Kelowna BC
    Posts
    53
    Quote Originally Posted by 1stDeuce View Post
    I'll try to get them migrated to expo soon, but in the meantime, there IS a workaround for some browsers!!
    Search "photobucket hotlink fix". You'll see apps for Firefox and Chrome. (If you're not using one of those two browsers, you need to start.)
    All you have to do is find the app, click the "install" button, and voila, pictures show up!
    Enjoy,
    Chris
    Frig Thank you so much! I had no idea that fix was out there.
    Seriously wicked build. Absolutely love the tan/black colour scheme. Comanches are so rare around here now.

Page 7 of 7 FirstFirst ... 567

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •