Thread: 98, ABS behavior questions

  1. #1
    Join Date
    Apr 2015
    Location
    Michigan USA
    Posts
    405

    Default 98, ABS behavior questions

    I was playing in the snow a little tonight which turned into an ABS function test. I’m wondering if anyone can confirm this as normal. 1. My ABS only kicks on for about 3-4 seconds then cuts out. The highest speed I tested it at was 35 mph and it cut out well before I was anywhere near stopped. I did this repeatedly and it was the same every time. This was on fully snowed in paved road with very little traction but not ice. When the ABS was firing, it succeeded in controlling and slowing the vehicle, but a full slide resulted after it cut out. 2. When the ABS fires I can see an electrical drag enough to slightly dim headlights. 3. I need to test again but pretty sure when the ABS shuts off, if I lift off pedal and brake again, it will cycle a second time.

    If anyone could confirm this seems normal please chime in. My car (2004) ABS fires until the car stops.
    Last edited by Salonika; 12-25-2017 at 02:21 AM.
    1998 Montero Gen 2.5 C

  2. #2
    Join Date
    Apr 2015
    Location
    Michigan USA
    Posts
    405
    Bump
    1998 Montero Gen 2.5 C

  3. #3
    Join Date
    Apr 2015
    Location
    Michigan USA
    Posts
    405
    Bump.....can someone with a gen 2.5 in a wintery area do a hard stop on a slippery road from 35mph and let me know if the ABS fires until dead stop or does it cut out before you are stopped......thank you.
    1998 Montero Gen 2.5 C

  4. #4
    Join Date
    Aug 2015
    Location
    Indy
    Posts
    405
    Until dead stop for me.

  5. #5
    Join Date
    Mar 2014
    Location
    New Jersey
    Posts
    348
    That's definitely not normal, sounds like you have some issue with electrical power.

  6. #6
    Join Date
    Apr 2015
    Location
    Michigan USA
    Posts
    405
    No ABS light though, so whatever may be wrong, the self check isn’t picking it up. At slower speeds, say 10mph and under, the system does fire until completely stopped. I wouldn’t even know where to start here, plus I’d like to hear from a few more people first.
    1998 Montero Gen 2.5 C

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •